PC SOFT

WINDEV的在线文档

  • Overview
  • "User" tab
  • User and password
  • User dictionary
  • "General" tab
  • Startup
  • Automatic backup
  • Automatic retrieval
  • Forcing the flush
  • Speeding up the environment
  • Source Code Manager (SCM)
  • "Web" tab
  • "Translation" tab
  • Configuring the translation options
  • Using the automatic translation
  • "Directories" tab
  • Directories of the optional elements
  • "Help" tab
  • "The "don't display anymore"" tab
  • "AAD" tab
文档页面当前正在翻译。对于此延迟我们深表歉意。
您可以自愿地帮助我们翻译您想要的文档段落,然后只需通过以下地址与我们联系:info@cn.windev.com
产品
WinDevWebDev-服务器代码WebDev-浏览器代码WinDev Mobile报表和查询
平台
WindowsLinuxWindows MobileWindows PhoneWindows Store appsAndroidAndroid Widget iPhone/iPad
语言
JavaPHPAjax用户代码(MCU)外部语言
数据库
HFSQLHFSQL Client/Server存储过程HF 5.5OLE DBODBC本地访问

Overview
The general options are used to configure the work environment of the product used.

These options affect:

WinDev To display the options of WinDev, select "Tools .. Options .. General options of WinDev".
WinDev To display the options of WinDev: on the "首页" pane, in the "环境" group, expand "选项" and select "General options of WinDev".

"User" tab

User and password

The "User" tab is used to manage the characteristics of the current user.

You can:

  • Find out the current user and change his password if necessary ("Password" button). When changing password, all you have to do is type:
    • the current password,
    • the new password and its confirmation.
  • Request the password at startup: This option is used to enable (or not) the login window when starting the product. This window is used enter the name of the user and the associated password.
  • 19版本和更高版本
    Synchronize the environnement in the Control Centers: This option is used to save the environment in the Control Centers. In this case, the environment defined by the developer (position of panes, displayed panes, ...) will be linked to the login for connecting to WinDev, WebDev or WinDev Mobile. The user will be able to access his custom environment from any computer linked to the database of Control Centers.
    19新版本
    Synchronize the environnement in the Control Centers: This option is used to save the environment in the Control Centers. In this case, the environment defined by the developer (position of panes, displayed panes, ...) will be linked to the login for connecting to WinDev, WebDev or WinDev Mobile. The user will be able to access his custom environment from any computer linked to the database of Control Centers.
    Synchronize the environnement in the Control Centers: This option is used to save the environment in the Control Centers. In this case, the environment defined by the developer (position of panes, displayed panes, ...) will be linked to the login for connecting to WinDev, WebDev or WinDev Mobile. The user will be able to access his custom environment from any computer linked to the database of Control Centers.
  • Modify the parameters of Control Centers ("Parameters of Control Centers" button). This allows you to find out the current setting of the data files found in the Control Centers and to redefine these parameters if necessary. See Database of Control Centers for more details.

User dictionary

A specific dictionary can be defined for each user.

The elements found in this dictionary (controls, windows, ...) can be directly accessed from the "Wizards, Examples and Components" pane ("User" option).

See User dictionary for more details.

"General" tab

Startup

The options found in the "Startup" section are as follows:
  • Load the last project: This option is used to automatically load the last project opened for the current product.
  • Number of last projects and documents used: These options allow you to configure the number of last projects and the number of last elements displayed in this list. All you have to do is select the requested element or project to open it directly in the corresponding editor.
    The last documents and projects used are displayed at the end of the "File" menu of WinDev, WebDev or WinDev Mobile.
    The last documents and projects used are displayed at the end of the options used to open a project:
    • among the quick access buttons. All you have to do is expand this option to find the last files used ("Recent files") and the last projects use ("Recent projects"):
    • on the "首页" pane, in the "常规" group, expand "打开".
Notes:
  • The maximum number of projects that can be displayed in this list is set to 10.
  • The maximum number of elements that can be displayed is set to 10.
  • 19版本和更高版本
    Let Windows manage the editor DPI: By default, the editors of WinDev, WebDev and WinDev Mobile specifically manage their display according to the screen resolution . We advise you to check this option when the default management mode does not allow to properly view the character font used for the editor options, especially for the small screens with large DPI (Macbook Retina).
    Caution: this setting affects the editors for the development only. It has no effect on the developed applications. For the developed applications, this setting can be modified in the description window of windows ("GUI" tab, "The window and controls are enlarged" option).
    19新版本
    Let Windows manage the editor DPI: By default, the editors of WinDev, WebDev and WinDev Mobile specifically manage their display according to the screen resolution . We advise you to check this option when the default management mode does not allow to properly view the character font used for the editor options, especially for the small screens with large DPI (Macbook Retina).
    Caution: this setting affects the editors for the development only. It has no effect on the developed applications. For the developed applications, this setting can be modified in the description window of windows ("GUI" tab, "The window and controls are enlarged" option).
    Let Windows manage the editor DPI: By default, the editors of WinDev, WebDev and WinDev Mobile specifically manage their display according to the screen resolution . We advise you to check this option when the default management mode does not allow to properly view the character font used for the editor options, especially for the small screens with large DPI (Macbook Retina).
    Caution: this setting affects the editors for the development only. It has no effect on the developed applications. For the developed applications, this setting can be modified in the description window of windows ("GUI" tab, "The window and controls are enlarged" option).

Automatic backup

If "Manage the automatic backup of project elements" is checked, two archive files will be generated for each element used (window, report, class, ...):
  • The files with a ".BK*" extension (".BKW", ".BKE", ".BKR", ...)
    The file with a BK* extension is created during the first backup of the object after the project opening. It corresponds to the version of the object when opening the project.
    The BK* file allows you to retrieve a project, ... in the status it was before the project was opened in the editor.
  • The files with a ".TK*" extension (".TKW", ".TKE", ".TKR", ...)
    The file with a TK* extension is created whenever the object is saved. It corresponds to the N-1 status of the object.
    The TK* file is used to retrieve a project, a window, ... in the status it was before the last backup performed in the editor.
The ".BK*" and ".TK*" files are saved in the "Backup" directory of your project.

The option "Allow the projects coming from an earlier version to be opened without backup" is used not to automate the project backup when going to a major version of the product. Indeed, for any project created with an earlier version, a backup is performed by default (in the project directory) before opening the project with the new version. If this option is checked, only the request for backup will be performed.

Automatic retrieval

To avoid problems when a system lock occurs (power outage for example), WinDev, WinDev and WinDev Mobile propose a system used to automatically retrieve the elements (queries, reports, windows, ...) opened in the different editors. This mechanism is enabled by the "Backup for automatic retrieval every XX minutes" option.

When this system is enabled:

  • An automatic backup of the open elements is regularly performed at specific time intervals (every 10 minutes by default).
  • When an element is re-opened after a system lockup, a window for automatic retrieval is displayed. This window proposes to retrieve:
    • the element as it was during the last backup performed by the developer.
    • the element automatically saved by WinDev, WebDev or WinDev Mobile.
The selected version is automatically opened in the corresponding editor. The unselected version is available in the window for version management ("File .. Versions") and it can be opened at any time.

See Managing the versions for more details.

Forcing the flush

By default, all the write operations performed by WinDev, WebDev or WinDev Mobile (saving the project elements, ...) are not immediately performed on the network disks.

To force this writing and to avoid using "caches", check "Force the flush". This option may slow down some features of the product used (compilation of the project for example). We recommend that you use this option for the projects shared between several developers.

Note: This option has no effect on the execution of the WinDev, WebDev and WinDev Mobile applications.

Speeding up the environment

To speed up the environment, you can:
  • Enable the "No tansparency" display mode. The windows of the environment can be displayed with or without transparency effects. If the "No transparency" display mode is enabled, the development environment will be faster.
  • Disable the spelling checker. By default, the environment is using the spelling checker of Open Office. This checker allows you to get real-time spell checking by using the Open Office dictionary. You have the ability to disable this checker. See Checking the spelling for more details.
  • Disabling the speech recognition. The environment responds to the voice commands (from Windows Vista). This speech recognition can be disabled. See Voice commands in the environment for more details.
  • 19版本和更高版本
    Disable the business rules: Loading the business rules found in the database of Control Centers may slow down the display of elements in the editor or the loading of the description window. This option is recommended when using a slow network or during a development via the Cloud.
    Caution: In this case, the business rules are disabled.
    19新版本
    Disable the business rules: Loading the business rules found in the database of Control Centers may slow down the display of elements in the editor or the loading of the description window. This option is recommended when using a slow network or during a development via the Cloud.
    Caution: In this case, the business rules are disabled.
    Disable the business rules: Loading the business rules found in the database of Control Centers may slow down the display of elements in the editor or the loading of the description window. This option is recommended when using a slow network or during a development via the Cloud.
    Caution: In this case, the business rules are disabled.

Source Code Manager (SCM)

The options of WinDev, WebDev and WinDev Mobile allow you to configure the check-out mode for the elements of a project found in the SCM.

Two check-out modes are available for the project elements:

  • The standard mode: If you display a SCM element that is not checked out, a panel indicates that the element must be checked out before it can be modified.
  • The automatic mode: If you try to modify a SCM element that is not checked out, the SCM automatically proposes to check out this element. Caution: This mode is not recommended when using the SCM over a slow Internet connection.
The option "Check out the elements during the first modification" is used to switch from the standard mode (option not checked) to the automatic mode (option checked).

See Checking out an element for more details.

Caution: This option is available only if you use a full environment or if the SCM is enabled in your environment. See Configuring the development environment for more details.

"Web" tab

"Translation" tab

Configuring the translation options

If your project is multilingual, the characteristics of an element (title of the window, caption of a control, ...) must be entered in all the languages of your application.

You can:

  • Enable the automatic change of input regional settings: This option allows you to automatically enable the language used by the keyboard when the mouse cursor is positioned in an input area of a language that is using a specific character set.
  • Select a specific translation engine: the specified translation software will be used to allow an automatic translation from the interface of the product of the different elements to translate. The translation software used can be:
    • WDDixio,
    • a specific software.
      In this case, you have the ability to configure the mode for transferring the information to translate from WinDev, WebDev or WinDev Mobile to the software used as well as the mode for retrieving the translated information from the translation software.
    • an Internet site.
      In this case, during a click on the "Translate" button, the text to translate is copied into the clipboard and the Web site is automatically opened. There is no return or direct translation in this mode.
    • 18版本和更高版本
      Google Translation. In this case, you must specify the API key expected by Google Traduction. See Performing a translation with Google Traduction for more details.
      Note: you must comply with the rules for using the service via Google.
      18新版本
      Google Translation. In this case, you must specify the API key expected by Google Traduction. See Performing a translation with Google Traduction for more details.
      Note: you must comply with the rules for using the service via Google.
      Google Translation. In this case, you must specify the API key expected by Google Traduction. See Performing a translation with Google Traduction for more details.
      Note: you must comply with the rules for using the service via Google.
  • Select the supported languages (source language and destination language).
Notes:
  • To configure the transfer mode properly, see the documentation supplied with your translation software.
  • WDDixio is a multilingual dictionary supplied with WDMSG. Contact PC SOFT Sales Department for more details about the conditions for using this product.

Using the automatic translation

To use the automatic translation that was configured beforehand:
  1. Select the text to translate (the caption in the description window of the control for example).
  2. Click the "Translate" button (available in the description window of the control for example).
  3. Retrieve the translation according to the options chosen when configuring the automatic translation (paste into the translated area for example).
See Multilingual applications for more details.

"Directories" tab

Directories of the optional elements

This option allows you to configure the directories used by default by the optional elements of the product used:
  • The personal projects: directory proposed by default when creating a project.
  • The help files: directory of the product help.
  • The goodies: directory containing buttons with preset appearance.
  • The skin templates: directory containing the different application styles that can be applied to your projects or to your windows.
  • The tutorial: directory of the examples used by the tutorial.
  • The examples: directory of the examples supplied with the product.
  • The videos: directory of the overview videos.
  • The code bricks: directory containing the code bricks
  • The messages: directory containing the database of custom messages.
For each element, the [...] button allows you to customize each one of the directories (if the product is used in network for example).

"Help" tab
This tab is used to define the use mode of the online help.

The online help is available:

  • locally: the help files are installed on the development computer. The help is displayed in a special help browser.
  • on the Internet: the Internet online help is available from any computer equipped with an Internet access, without the product being necessarily installed. This help is updated on a regular basis.
To use:
  • the local help, all you have to do is select "Use the local help database"
  • the Internet help, all you have to do is select "Use the help database via Internet".the Internet help, all you have to do is select "Use the online help".
This tab is also used to filter the displayed help. You can:
  • Display the help for all the products: the help common to WinDev, WebDev, WinDev Mobile and Reports and Queries will be displayed. All the paragraphs specific to a product will be shown. All the index entries (even the ones specific to a given product) will be accessible.
  • Display the help for the current product only: only the help pages relevant to the current product will be accessible. Notes regarding other products will not be shown.
See How to access the help for more details.

"The "don't display anymore"" tab
This tab is used to list all the messages for which "Don't display anymore" has been checked. The messages found in this list are not displayed in the environment anymore.

To re-enable a message, all you have to do is uncheck this message.

See Management of "Don't display anymore" for more details.

"AAD" tab
This tab is used to configure the Assisted Application Development (AAD).

You can:

  • Specify the position of the AAD tooltip.
  • Request to be notified about new AAD tips.
  • Request a confirmation before running the selected AAD.
The list of disabled tips is displayed. To re-enable a tip, all you have to do is check the corresponding line.

See Assisted Application Development (AAD) for more details.